products downloads purchase contact us

Kagi Webstore Errors / Registering with beta versions of Safari
Tech Library Article #0010 + Created: 7 October 2004 + Modified: 10 May 2007

If you experience an error when ordering via our Kagi webstore, please try again a few minutes later. If the error repeats, please contact us for assistance.

In general, the Kagi webstore is very stable and works with most current browsers.

Some users have reported errors when using early beta versions of Safari to place orders through Kagi. If this happens, we recommend using version 1.x or later of Safari, or another browser, such as Netscape, Mozilla, Firefox, Camino, or Internet Explorer. This does not apply, of course, to current non-beta versions of Safari. (This was a problem a couple of years ago when Safari was only available as a beta application--which is no longer the situation.)